re = /@[\h\pL]+\(([^)]+)\)\h\{([^}]+)\}\K/m
str = '@loop (<ВЗЯТЬ ПЕРВЫЙ ТЕКCТ>) {<ВЗЯТЬ ВТОРОЙ ТЕКCТ>}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end