package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\+]?[(]?[0-9]{3}[)]?[-\s\.]?[0-9]{3}[-\s\.]?[0-9]{4,6}$`)
var str = `+919367788755
8989829304
+16308520397
786-307-3615
789
123765
1-1-1
+982`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}