import re
regex = re.compile(r"^[\+]?[(]?[0-9]{3}[)]?[-\s\.]?[0-9]{3}[-\s\.]?[0-9]{4,6}$", flags=re.MULTILINE)
test_str = ("+919367788755\n"
"8989829304\n"
"+16308520397\n"
"786-307-3615\n"
"789\n"
"123765\n"
"1-1-1\n"
"+982")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")