// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{4}\-[A-Z]{4}\-[A-Z]{4}").unwrap();
let string = "specific text string here AAAA-BBBB-XXXX variable text string after";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}