using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)(?:^\^|^ERROR).*?(?=\r?\nABC>)";
string input = @"ABC>W !,MSG
ERROR^BATCH~Batch in use
ABC>space ""ABC""";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}