re = /(?sm)(?:^\^|^ERROR).*?(?=\r?\nABC>)/i
str = 'ABC>W !,MSG
ERROR^BATCH~Batch in use
ABC>space "ABC"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end