package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9,]{0,3}[x][0-9,]{0,6}$`)
var str = `1x21
2,2x1
3,3x1,2
33x1,1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}