$re = '/^[0-9,]{0,3}[x][0-9,]{0,6}$/m';
$str = '1x21
2,2x1
3,3x1,2
33x1,1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);