package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[A-Z]{2}.*$`)
var str = `abc AB C 2
sasd 23
123 DTDFD e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}