$re = '/^.*[A-Z]{2}.*$/m';
$str = 'abc AB C 2
sasd 23
123 DTDFD e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);