package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(1[89]|[2-9][0-9])$`)
var str = `99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}