$re = '/^(1[89]|[2-9][0-9])$/';
$str = '99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);