re = /(?<=rbl-value:)\w+\b/m
str = 'asd123 ghjkasd rbl-value:inputName hjlqwezuo rbl-value:something asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end