#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(E1E\w{4,5})-(\d{2,3})-(\d{2,3});("(\w{1,3})\W*\n(E1E\w{4,5})-(\d{2,3})-(\d{2,3})[^"]+")?"
Local $sString = "" Xpath входящего формата" & @CRLF & _
" Допустипы значения: XPath, ""константа""- должна быть в 1 столбце(<E0065>RECADV</E0065>), ""enum(, , ,)"" - если поле может принимать фиксированный набор значений" & @CRLF & _
"";квалификатор" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"hardcode=Сфера КУРЬЕР;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"hardcode=02;" & @CRLF & _
";" & @CRLF & _
"E1EDK02-67;" & @CRLF & _
"E1EDK03-67;" & @CRLF & _
"hardcode=643;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDKA1-101-135;"WE " & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"hardcode=4025413896;" & @CRLF & _
"hardcode=997850001;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDKA1-719-721;"WE " & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-390-398;"WE " & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-346-380;"WE " & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-241-275;"WE " & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDK28-224-253;" & @CRLF & _
";" & @CRLF & _
"E1EDK28-84-153;" & @CRLF & _
"E1EDK28-67-83;" & @CRLF & _
"E1EDK28-154-223;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDKA1-101-135;"RG" & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"hardcode=4025413896;" & @CRLF & _
"hardcode=997850001;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDKA1-719-721;"RG" & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-390-398;"RG" & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-346-380;"RG" & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
"E1EDKA1-241-275;"RG" & @CRLF & _
"E1EDKA1-64-66 (3)"" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDP01-64-69;" & @CRLF & _
"E1EDP19-102-171;" & @CRLF & _
"E1EDK01-218-220;" & @CRLF & _
"E1EDP26-64-66;" & @CRLF & _
";" & @CRLF & _
"Calculation;" & @CRLF & _
"E1EDP05-177-191;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDP04-71-87;" & @CRLF & _
"hardcode=процент;" & @CRLF & _
";" & @CRLF & _
"E1EDP04-88-105;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"E1EDS01-67-84;"10" & @CRLF & _
"E1EDS01-64-66 (3)"" & @CRLF & _
"E1EDS01-67-84;"11" & @CRLF & _
"E1EDS01-64-66 (3)"" & @CRLF & _
"E1EDS01-67-84;"5 " & @CRLF & _
"E1EDS01-64-66 (3)"" & @CRLF & _
"E1EDS01-67-84;"5 " & @CRLF & _
"E1EDS01-64-66 (3)"" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
"hardcode=4025413896;" & @CRLF & _
"hardcode=Руководитель секции управления сервисной сетью в странах СНГ;" & @CRLF & _
";" & @CRLF & _
"hardcode=Нигматуллин ;" & @CRLF & _
"hardcode=Ринат ;" & @CRLF & _
"hardcode=Фаритович;" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
";" & @CRLF & _
""
Local $sSubst = "gir:parseIdoc('$1',$2,$3,'$5',$7)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)