import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(E1E\\w{4,5})-(\\d{2,3})-(\\d{2,3});(\"(\\w{1,3})\\W*\\n(E1E\\w{4,5})-(\\d{2,3})-(\\d{2,3})[^\"]+\")?";
final String string = "\" Xpath входящего формата\n"
+ " Допустипы значения: XPath, \"\"константа\"\"- должна быть в 1 столбце(<E0065>RECADV</E0065>), \"\"enum(, , ,)\"\" - если поле может принимать фиксированный набор значений\n"
+ "\";квалификатор\n"
+ ";\n"
+ ";\n"
+ "hardcode=Сфера КУРЬЕР;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "hardcode=02;\n"
+ ";\n"
+ "E1EDK02-67;\n"
+ "E1EDK03-67;\n"
+ "hardcode=643;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDKA1-101-135;\"WE \n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "hardcode=4025413896;\n"
+ "hardcode=997850001;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDKA1-719-721;\"WE \n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-390-398;\"WE \n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-346-380;\"WE \n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-241-275;\"WE \n"
+ "E1EDKA1-64-66 (3)\"\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDK28-224-253;\n"
+ ";\n"
+ "E1EDK28-84-153;\n"
+ "E1EDK28-67-83;\n"
+ "E1EDK28-154-223;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDKA1-101-135;\"RG\n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "hardcode=4025413896;\n"
+ "hardcode=997850001;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDKA1-719-721;\"RG\n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-390-398;\"RG\n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-346-380;\"RG\n"
+ "E1EDKA1-64-66 (3)\"\n"
+ "E1EDKA1-241-275;\"RG\n"
+ "E1EDKA1-64-66 (3)\"\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDP01-64-69;\n"
+ "E1EDP19-102-171;\n"
+ "E1EDK01-218-220;\n"
+ "E1EDP26-64-66;\n"
+ ";\n"
+ "Calculation;\n"
+ "E1EDP05-177-191;\n"
+ ";\n"
+ ";\n"
+ "E1EDP04-71-87;\n"
+ "hardcode=процент;\n"
+ ";\n"
+ "E1EDP04-88-105;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "E1EDS01-67-84;\"10\n"
+ "E1EDS01-64-66 (3)\"\n"
+ "E1EDS01-67-84;\"11\n"
+ "E1EDS01-64-66 (3)\"\n"
+ "E1EDS01-67-84;\"5 \n"
+ "E1EDS01-64-66 (3)\"\n"
+ "E1EDS01-67-84;\"5 \n"
+ "E1EDS01-64-66 (3)\"\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ "hardcode=4025413896;\n"
+ "hardcode=Руководитель секции управления сервисной сетью в странах СНГ;\n"
+ ";\n"
+ "hardcode=Нигматуллин ;\n"
+ "hardcode=Ринат ;\n"
+ "hardcode=Фаритович;\n"
+ ";\n"
+ ";\n"
+ ";\n"
+ ";\n";
final String subst = "gir:parseIdoc('$1',$2,$3,'$5',$7)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}