#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(??$)(?!.*\d[wWeEnNsS]\d)(?!.*[wWeEnNsS][^0-9\n]).+$"
Local $sString = "Following are examples of valid inputs:" & @CRLF & _
"" & @CRLF & _
"w234" & @CRLF & _
"W234" & @CRLF & _
"E234" & @CRLF & _
"234w" & @CRLF & _
"234" & @CRLF & _
"" & @CRLF & _
"Invalid inputs:" & @CRLF & _
"" & @CRLF & _
"w234w" & @CRLF & _
"2w34" & @CRLF & _
"ww234" & @CRLF & _
"we234" & @CRLF & _
"w234e" & @CRLF & _
"w"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")