$re = '/^(??$)(?!.*\d[wWeEnNsS]\d)(?!.*[wWeEnNsS][^0-9\n]).+$/m';
$str = 'Following are examples of valid inputs:
w234
W234
E234
234w
234
Invalid inputs:
w234w
2w34
ww234
we234
w234e
w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);