import re
regex = re.compile(r"(<\?php echo L10n\:\:icon\(')(.*?)('\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)(.*?)(\); \?\>)", flags=re.MULTILINE)
test_str = ("<?php echo L10n::icon('calendar'); ?>\n"
" <?php echo UI::timeago($License->iso_8601_purchased, $License->purchased); ?>")
subst = "$6$7, '$2'$8"
result = regex.sub(subst, test_str)
if result:
print(result)