import re
regex = re.compile(r"(\w*)=(\".*?\"|\S*)", flags=re.MULTILINE)
test_str = ("Message meets Alert condition\n\n"
"date=2020-08-20 time=00:33:57 devname=FGT3HD3999906624 devid=FGT3HD3999906624 logid=\"0100032003\" type=\"event\" subtype=\"system\" level=\"information\" vd=\"root\" eventtime=1597847637407862934 tz=\"+1000\" logdesc=\"Admin logout successful\" sn=\"159999794\" user=\"admin\" ui=\"https(10.198.199.105)\" method=\"https\" srcip=10.198.199.105 dstip=192.168.23.254 action=\"logout\" status=\"success\" duration=4843 reason=\"timeout\" msg=\"Administrator admin timed out on https(10.198.199.105)\"\n\n"
"Administrator IT Administrator Ph:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")