import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,3}\\.){3}\\d{3}.*[a|A]dmin.*40[3|4]";
final String string = "80.13.134.108 - - [16/May/2018:08:19:46 +0100] \"GET /admin/pma/index.php HTTP/1.1\" 404 217 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:46 +0100] \"GET /admin/PMA/index.php HTTP/1.1\" 404 217 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/mysql/index.php HTTP/1.1\" 404 219 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/mysql2/index.php HTTP/1.1\" 404 220 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /pma/index.php HTTP/1.1\" 404 211 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /PMA/index.php HTTP/1.1\" 404 211 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpmyadmin/index.php HTTP/1.1\" 404 224 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpMyAdmin/index.php HTTP/1.1\" 404 224 \"-\" \"Mozilla/5.0\"\n"
+ "80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpmyadmin2/index.php HTTP/1.1\" 404 225 \"-\" \"Mozilla/5.0\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}