# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{1,3}\.){3}\d{3}.*[a|A]dmin.*40[3|4]"
test_str = ("80.13.134.108 - - [16/May/2018:08:19:46 +0100] \"GET /admin/pma/index.php HTTP/1.1\" 404 217 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:46 +0100] \"GET /admin/PMA/index.php HTTP/1.1\" 404 217 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/mysql/index.php HTTP/1.1\" 404 219 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/mysql2/index.php HTTP/1.1\" 404 220 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /pma/index.php HTTP/1.1\" 404 211 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /PMA/index.php HTTP/1.1\" 404 211 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpmyadmin/index.php HTTP/1.1\" 404 224 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpMyAdmin/index.php HTTP/1.1\" 404 224 \"-\" \"Mozilla/5.0\"\n"
"80.13.134.108 - - [16/May/2018:08:19:47 +0100] \"GET /admin/phpmyadmin2/index.php HTTP/1.1\" 404 225 \"-\" \"Mozilla/5.0\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.