package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)->\s(\w+:\s\w+(?:==)?)\s<-`)
var str = `-> BAMAuthToken: JSyoNMTU3OTI3OTE2NzM4MjphdXRvNTMy <-
-> BAMAuthToken: JSyoNMTU3OTI3OTE2NzM4MjphdXRvNTMy== <-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}