re = /->\s(\w+:\s\w+(?:==)?)\s<-/m
str = '-> BAMAuthToken: JSyoNMTU3OTI3OTE2NzM4MjphdXRvNTMy <-
-> BAMAuthToken: JSyoNMTU3OTI3OTE2NzM4MjphdXRvNTMy== <-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end