using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:https?://)?(?:www\.)?youtube\.com/)(?:watch\?v=|v/)([a-zA-Z0-9_]*)";
string input = @"youtube.com/watch?v=GQQMLE4FuIQ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}