re = /^(?:(?:https?:\/\/)?(?:www\.)?youtube\.com\/)(?:watch\?v=|v\/)([a-zA-Z0-9_]*)/
str = 'youtube.com/watch?v=GQQMLE4FuIQ'
# Print the match result
str.match(re) do |match|
    puts match.to_s
end