package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{3})[ -]?(\d{3})[ -]?(\d{4})`)
var str = `1234567890
123 456 7890
123-456-7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}