$re = '/(\d{3})[ -]?(\d{3})[ -]?(\d{4})/m';
$str = '1234567890
123 456 7890
123-456-7890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);