import re
regex = re.compile(r"ticky: (INFO|ERROR)(: [\w\W $]+?)(\([\w]*\))", flags=re.MULTILINE)
test_str = ("May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (coleman)\n"
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Tried to add information to a closed ticket (ldelfino)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")