$re = '/^CH([0-3][\d]{0,5})$/';
$str = 'CH300000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);