re = /^(?!.*(?=AA.*XX.*ZZ).*).*AA.*ZZ.*$/m
str = 'IYAABMDHRPONWUYZZ
BVAABDMYBXXWZZCKU
AABMDHRPONWUYXxXxXxZZ
BVAABDZZMYBXXWCKU
anythingelse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end