import re
regex = re.compile(r"# --*[\S\s]*---", flags=re.MULTILINE)
test_str = ("# ---------------------------------------------------------------------------------------------------------------------\n"
"# MODULE PARAMETERS\n"
"# These are the variables we have to pass in to use the module specified in the terragrunt configuration above\n"
"# ---------------------------------------------------------------------------------------------------------------------\n\n"
"foo\n\n"
"bar\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")