re = /# --*[\S\s]*---/m
str = '# ---------------------------------------------------------------------------------------------------------------------
# MODULE PARAMETERS
# These are the variables we have to pass in to use the module specified in the terragrunt configuration above
# ---------------------------------------------------------------------------------------------------------------------
foo
bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end