re = /#'YOUR_ANSWER.*(?:\R(?!\h*#'END_ANSWER$).*)*\R\h*#'END_ANSWER$/m
str = '#\'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
'
subst = 'space for answer'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result