#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=AS \()([^\(\)]*(\([^\(\)]*\))?[^\(\)]*)*(?=\))"
Local $sString = "WITH Sales_Cust_Join_CTE" & @CRLF & _
"AS ( SELECT fs.OrderDateKey,fs.ProductKey,fs.OrderQuantity ,fs.UnitPrice AS TotalSale ,dc.FirstName,dc.LastName FROM [dbo].[FactInternetSales] fs INNER JOIN [dbo].[DimCustomer] dc ON dc.CustomerKey = fs.CustomerKey ) ,Date_CTE" & @CRLF & _
"AS ( SELECT DateKey ,CalendarYear FROM [dbo].[DimDate] )" & @CRLF & _
"SELECT CalendarYear ,ProductKey ,SUM(TotalSale) AS TotalSales" & @CRLF & _
"FROM Sales_Cust_Join_CTE" & @CRLF & _
"INNER JOIN Date_CTE ON Date_CTE.DateKey = Sales_Cust_Join_CTE.OrderDateKey" & @CRLF & _
"GROUP BY CalendarYear ,ProductKey" & @CRLF & _
"ORDER BY CalendarYear ASC ,TotalSales DESC" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")