# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=AS \()([^\(\)]*(\([^\(\)]*\))?[^\(\)]*)*(?=\))"
test_str = ("WITH Sales_Cust_Join_CTE\n"
"AS ( SELECT fs.OrderDateKey,fs.ProductKey,fs.OrderQuantity ,fs.UnitPrice AS TotalSale ,dc.FirstName,dc.LastName FROM [dbo].[FactInternetSales] fs INNER JOIN [dbo].[DimCustomer] dc ON dc.CustomerKey = fs.CustomerKey ) ,Date_CTE\n"
"AS ( SELECT DateKey ,CalendarYear FROM [dbo].[DimDate] )\n"
"SELECT CalendarYear ,ProductKey ,SUM(TotalSale) AS TotalSales\n"
"FROM Sales_Cust_Join_CTE\n"
"INNER JOIN Date_CTE ON Date_CTE.DateKey = Sales_Cust_Join_CTE.OrderDateKey\n"
"GROUP BY CalendarYear ,ProductKey\n"
"ORDER BY CalendarYear ASC ,TotalSales DESC\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.