package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[1-9]\d*|09)$`)
var str = `hostname09
hostname04
hostname01
hostname10
hostname660
hostname99
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}