re = /(?:[1-9]\d*|09)$/m
str = 'hostname09
hostname04
hostname01
hostname10
hostname660
hostname99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end