re = /\(((?>\\.|[^()])+)\)/m
str = 'a(bb)(cc)dd\\(ee\\)(ff)(gg\\(hh\\)ii)jj()kk(\\(\\))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end