package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.odp|ods|odt$)`)
var str = `blocb.odt`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}