const regex = /(\.odp|ods|odt$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.odp|ods|odt$)', '')
const str = `blocb.odt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}