package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(a)?:([\w]{2,32}):([\d]{18,28})>`)
var str = `<:typescript:996832147874795601>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}