$re = '/<(a)?:([\w]{2,32}):([\d]{18,28})>/m';
$str = '<:typescript:996832147874795601>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);