package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([[:lower:]]{3,6}-)|([[:lower:]]{3,6} ?))\d{1,3}$`)
var str = `abc 1
Abc 2
abc-123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}