// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([[:lower:]]{3,6}-)|([[:lower:]]{3,6} ?))\d{1,3}$").unwrap();
let string = "abc 1
Abc 2
abc-123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}