using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+:)([""']?)(.+)\2";
string input = @"category:""live casino"" gsp:S1aik-UBnl
aa:""b"" c:'d e' f:g";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}