re = /([\w]+:)(["']?)(.+)\2/
str = 'category:"live casino" gsp:S1aik-UBnl
aa:"b" c:\'d e\' f:g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end