using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\|]?([a-z0-9A-Z]+)(?:[\(]?[,][\)]?)?[\|]?";
string input = @"|Func(param1, param2, param32, param54, param293, par13am, param)|";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}