// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\|]?([a-z0-9A-Z]+)(?:[\(]?[,][\)]?)?[\|]?").unwrap();
let string = "|Func(param1, param2, param32, param54, param293, par13am, param)|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}