re = /(?:!|\G(?!^))\K(abc|123)(?=(?:abc|123)*!)/
str = '!123abcabc123!123abcabc123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end