import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MATCH\\s*\\(\\K\\s*COALESCE\\s*\\(\\s*([^,)]+)(?:,[^)]*)?\\)(?=\\)\\s*AGAINST)";
final String string = "WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0\n"
+ "WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}